Zimbra

Catch All
https://wiki.zimbra.com/wiki/Managing_Domains

Adding multiple catchalls

zimbra@zimbra:~$ zmprov modifyAccount catchall@user.com zimbraMailCAtchAllAddress @domain1.com
zimbra@zimbra:~$ zmprov modifyAccount catchall@user.com +zimbraMailCAtchAllAddress @domain2.com
zimbra@zimbra:~$ zmprov modifyAccount catchall@user.com +zimbraMailCAtchAllAddress @domain3.com

 

MTA
https://wiki.zimbra.com/wiki/Sending_mail_through_an_external_relay

Advertisements

ACME.SH SSL

https://github.com/Neilpang/acme.sh

 

acme.sh –issue -d test.com -w /httpd/test.com/www/
[Wed Mar 14 14:56:37 UTC 2018] Single domain=’test.com’
[Wed Mar 14 14:56:37 UTC 2018] Getting domain auth token for each domain
[Wed Mar 14 14:56:37 UTC 2018] Getting webroot for domain=’test.com’
[Wed Mar 14 14:56:37 UTC 2018] Getting new-authz for domain=’test.com’
[Wed Mar 14 14:56:38 UTC 2018] The new-authz request is ok.
[Wed Mar 14 14:56:38 UTC 2018] Verifying:test.com
[Wed Mar 14 14:56:41 UTC 2018] Success
[Wed Mar 14 14:56:41 UTC 2018] Verify finished, start to sign.
[Wed Mar 14 14:56:42 UTC 2018] Cert success.
—–BEGIN CERTIFICATE—–
….
—–END CERTIFICATE—–
[Wed Mar 14 14:56:42 UTC 2018] Your cert is in /root/.acme.sh/test.com/test.com.cer
[Wed Mar 14 14:56:42 UTC 2018] Your cert key is in /root/.acme.sh/test.com/test.com.key
[Wed Mar 14 14:56:42 UTC 2018] The intermediate CA cert is in /root/.acme.sh/test.com/ca.cer
[Wed Mar 14 14:56:42 UTC 2018] And the full chain certs is there: /root/.acme.sh/test.com/fullchain.cer

SHA Messing around

01100101001100110110001000110000011000110011010000110100001100100011100100111000011001100110001100110001011000110011000100110100001110010110000101100110011000100110011000110100011000110011100000111001001110010011011001100110011000100011100100110010001101000011001000110111011000010110010100110100001100010110010100110100001101100011010000111001011000100011100100110011001101000110001101100001001101000011100100110101001110010011100100110001011000100011011100111000001101010011001001100010001110000011010100110101

echo -n “” | sha256sum -b | awk {‘printf $1’} | xxd -b -c 1  | awk {‘print $2’} | paste -sd “” 

echo -n “” |
echo blank with no line feed ‘-n’ pipe out

sha256sum -b |
generate sha in binary ‘-b’ then pipe out

awk {‘printf $1’} |
awk $1 and printf to supress new LF then pipe out

xxd -b -c 4
xxd to turn into nice output

00000000: 01100101 00110011 01100010 00110000 e3b0
00000004: 01100011 00110100 00110100 00110010 c442
00000008: 00111001 00111000 01100110 01100011 98fc
0000000c: 00110001 01100011 00110001 00110100 1c14
00000010: 00111001 01100001 01100110 01100010 9afb
00000014: 01100110 00110100 01100011 00111000 f4c8
00000018: 00111001 00111001 00110110 01100110 996f
0000001c: 01100010 00111001 00110010 00110100 b924
00000020: 00110010 00110111 01100001 01100101 27ae
00000024: 00110100 00110001 01100101 00110100 41e4
00000028: 00110110 00110100 00111001 01100010 649b
0000002c: 00111001 00110011 00110100 01100011 934c
00000030: 01100001 00110100 00111001 00110101 a495
00000034: 00111001 00111001 00110001 01100010 991b
00000038: 00110111 00111000 00110101 00110010 7852
0000003c: 01100010 00111000 00110101 00110101 b855

Network – Cisco – IEEE Bridging

 

 

!
controller E1 0/0/0
clock source internal
channel-group 0 timeslots 1-31
!
controller E1 0/1/0
channel-group 0 timeslots 1-31
!
ip ssh version 2
!
!
!
bridge irb
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
bridge-group 1
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
bridge-group 2
!
interface Serial0/0/0:0
no ip address
bridge-group 1
!
interface Serial0/1/0:0
no ip address
bridge-group 2
!
interface BVI1
ip address dhcp
ip flow ingress
ipv6 address autoconfig
ipv6 nd autoconfig default-route
!
interface BVI2
no ip address
!
!
bridge 1 protocol ieee
bridge 1 route ip
!
bridge 2 protocol ieee
bridge 2 route ip
!
!

Network – Cisco – DSL

2dslBridging 2 ISP dsl services to VLANS using bridge groups
!
bridge irb
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
bridge-group 1
!
interface FastEthernet0/0.102
encapsulation dot1Q 102
bridge-group 2
!
interface ATM0/0/0
description iiNet
no ip address
logging event atm pvc state
no atm ilmi-keepalive
dsl operating-mode adsl2+
bridge-group 1
pvc 8/35
!
interface ATM0/1/0
description Internode
no ip address
logging event atm pvc state
no atm ilmi-keepalive
dsl operating-mode adsl2+
bridge-group 2
pvc 8/35
tx-ring-limit 3
encapsulation aal5snap
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

Network – Cisco – Digital Modems

 

ciacomicra

 

Its all about Channelized E1….. And the Modem CSM

MICA (Modem ISDN channel aggregation)

 

c3725

isdn switch-type primary-net5
!
controller E1 1/0
pri-group timeslots 1-31
!
interface Serial1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem
no cdp enable
!
line 65 94
modem InOut
transport input all

 

In modern c3825

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C3825-30DM
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
!
no aaa new-model
network-clock-participate wic 0
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
isdn switch-type primary-net5
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/0/0
pri-group timeslots 1-31
!
controller E1 0/0/1
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem 56
no cdp enable
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
!
!
!
!
!
!
!
!
line con 0
line aux 0
line 1/0 1/29
modem InOut
transport input all
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Network – Cisco – ISDN

!
card type e1 1
!
network-clock-participate E1 1/0
!
isdn switch-type primary-net5
!
controller E1 1/0
framing NO-CRC4
pri-group timeslots 1-31
!
!
interface Serial1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
!
dial-peer voice 1000 pots
destination-pattern 1…
port 1/0:15
forward-digits 4
!

Create a website or blog at WordPress.com

Up ↑